Techie Turmoil

April 2011

Canon iP1900 driver

2nd April 2011

Canon provide a Debian package for this printer, which is great. Unfortunately it will not install on recent distributions of Debian or Ubuntu, as it depends on old-school libcupsys2. I’ve repackaged them to adjust the dependency. Here is the modified version.